YouTube bookmarks enabled please!

Suggestions and comments you have for the forum
Post Reply
User avatar
ipso
Posts: 395
Joined: Sun Oct 10, 2010 12:18 am
Location: Santa Monica, California

YouTube bookmarks enabled please!

Post by ipso »

If possible.

This is the syntax to pinpoint specific moments in a video, but the valid URL is blocked (presumably) by motomaters sw – or is the thumbnail icon not pushed from YouTube?

[youtube]http://www.youtube.com/watch?v=DsPMbbtYJPE#t=0m17s[/youtube]

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Unfortunately, it isn't a simple fix. The problem is the # symbol. If I allow it to be used it opens up a security hole.

I'm trying to work out a solution.

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Hmmm...I found a way to get around the # problem but it doesn't seem to pass the time marker to Youtube.

How are you getting that URL? Are you just manually adding the #t=0m17s?

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Actually, this appears to be a Youtube issue. There is a URL translation that happens in order to embed a video. That translation doesn't support the timestamp.

To explain:

The URL you used,

http://www.youtube.com/watch?v=DsPMbbtYJPE#t=0m17s

becomes

http://www.youtube.com/v/DsPMbbtYJPE#t=0m17s

when it is embedded. However, Youtube apparenlty doesn't know what to do with the #t=0m17s at the end and just cuts it off.

I'll keep an eye out for a solution but I'm not real confident there is one.

User avatar
ipso
Posts: 395
Joined: Sun Oct 10, 2010 12:18 am
Location: Santa Monica, California

Re: YouTube bookmarks enabled please!

Post by ipso »

Yes – I manually add the time (t=) qualifier occasionally, as needed, (as a bookmark) to have a link jump right to a section of video (I wish there was the ability to do a second “closing” one as well – that would be the perfect! – to qualify a link that only shows the 20 seconds (or whatever) of a video you were referring to - but I don’t think YouTube supports that.

Here on this site, I can just use a html link with the fully qualified line vs. the bracketed/icon view.

Maybe something as simple as putting the link in quotes or something, inside the bracketed syntax, for an “escape” pass through – or in Frenchies {} - but you’ve tried that I guess.

User avatar
Richo
Posts: 917
Joined: Fri Aug 01, 2008 11:01 am
Location: Mildura. Australia.
Contact:

Re: YouTube bookmarks enabled please!

Post by Richo »

Not sure if you can do this or not, but is it possible to supply the width and height of the video when posting. I did a bit of searching on this but nothing seems to help much. The only method used on phpBB out there to get this to work means embedding the actual object (<object...) code. MM doesn't support this method so was wondering if there is any other way to do it.

The reason I ask this is that the default size is a small 4:3 format video and most new videos are now in 16:9 format, so it would be good to support this.

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Done.

I have to explicitely set the size in the code so I made it 711X400. I don't think this adversely effects videos in 4:3 but I am trying to find one to check on.

Let me know if anything behaves weirdly. or if a bigger or smaller size would be better.

User avatar
Richo
Posts: 917
Joined: Fri Aug 01, 2008 11:01 am
Location: Mildura. Australia.
Contact:

Re: YouTube bookmarks enabled please!

Post by Richo »

That looks much better Rats, thanks. It could possibly be a little smaller but thats just nit picking (maybe 640 wide).

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Yeah, after looking at them a little, I was thinking 640 as well.

User avatar
Richo
Posts: 917
Joined: Fri Aug 01, 2008 11:01 am
Location: Mildura. Australia.
Contact:

Re: YouTube bookmarks enabled please!

Post by Richo »

Almost right Rats. I think you need to make it a little higher. Yours is about 640x340 (including the chrome) and it should be about 640x390 (incl chrome).

User avatar
RatsMC
Posts: 5730
Joined: Wed May 21, 2008 10:15 pm
Location: Oakland

Re: YouTube bookmarks enabled please!

Post by RatsMC »

Richo wrote:Almost right Rats. I think you need to make it a little higher. Yours is about 640x340 (including the chrome) and it should be about 640x390 (incl chrome).

Well, apparently I can't type. I actually intended to make it 640x360.

You say it should be 390?


Edit: never mind. Checking the dimensions of on youtube itself, I see that it is, in fact 390.

User avatar
Richo
Posts: 917
Joined: Fri Aug 01, 2008 11:01 am
Location: Mildura. Australia.
Contact:

Re: YouTube bookmarks enabled please!

Post by Richo »

Nice. Looks much better now I think.

Post Reply